Bug 44415 - build error after applying KB3165756 to VS2015 update 3
Summary: build error after applying KB3165756 to VS2015 update 3
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 15.2
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-16 15:10 UTC by Nico Vermeir
Modified: 2017-05-30 19:19 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
compile error (28.92 KB, image/jpeg)
2016-09-16 15:10 UTC, Nico Vermeir
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Nico Vermeir 2016-09-16 15:10:34 UTC
Created attachment 17543 [details]
compile error

working on a xamarin forms project, everything compiles fine. I update VS 2015 with KB3165756 and I get the error in attachment. The project that throws the error is a PCL project.

Xamarin and Forms nuget packages are all up to date.
Pc running Win10 Enterprise Anniversary Update
Comment 2 Juan Marcelo Tondato 2016-12-23 14:55:24 UTC
Can you please add the following information?

1. Xamarin Logs
Go to the menu "Help - Xamarin - Zip Logs". Please attach that zip file to the bug report.
If you can connect to the Mac, then please run that command being connected to the Mac, that way we'll get the Mac logs as well.
If you cannot connect to the Mac, can you please zip and attach the content of the log files from the Mac located at "~/Library/Logs/Xamarin-4.3/"?.


2. Environment information
Go to the menu "Help - About Microsoft Visual Studio" and press "Copy Info". Please paste that info into a Bugzilla comment.

3. Diagnostic Build Output
Go to the menu "Tools - Options" and from the left panel: "Projects And Solutions - Build And Run" and change "MSBuild Output Verbosity" to "Diagnostic", and then build the solution. Copy the Build Output from the Output window and share it (maybe in a gist or as a zip file).

Thanks!
Comment 3 Juan Marcelo Tondato 2017-05-30 19:19:39 UTC
Hi,
As we've introduced several improvements around this area, I'll mark the bug as resolved fixed.
Please feel free to reopen it if you can still reproduce the issue with current bits.
Thanks!