Bug 44289 - Xamarin doesn't work with VS "15" Preview
Summary: Xamarin doesn't work with VS "15" Preview
Status: VERIFIED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- critical
Target Milestone: 4.2.1 (C8SR1)
Assignee: vga
URL:
: 44288 ()
Depends on:
Blocks:
 
Reported: 2016-09-14 12:43 UTC by Jonney Shih
Modified: 2016-09-15 03:52 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Jonney Shih 2016-09-14 12:43:19 UTC
# Steps to reproduce
Install Xamarin for VS package.

# Expected behavior
Xamarin installer detects VS Preview during installation and Xamarin visible under Tools menu in VS.

# Actual behavior
On VS "15" Preview 4: Xamarin installer doesn't detect VS.
On VS "15" Preview 1: Xamarin installer detects it but in VS there is no Xamarin extension installed.


# Supplemental info (logs, images, videos)
https://1drv.ms/u/s!Ato44WJy5buskm1CpGf3lXteVp1k
I reset the computer but the problem persists.
# Test environment (full version information)
Windows 10 64 bit, 14939.0
VS "15" Preview 4 using the new Installer (core editor + .Net Desktop without additional components)
All these versions had the same problem:
Xamarin.VisualStudio_4.2.0.675
Xamarin.VisualStudio_4.2.0.628
Xamarin.VisualStudio_4.2.0.586
Comment 1 vga 2016-09-14 14:09:41 UTC
*** Bug 44288 has been marked as a duplicate of this bug. ***
Comment 2 vga 2016-09-14 14:29:02 UTC
Installing C8 bits (4.2.x) into VS "15" Preview 4 is not officially supported at the moment.

VS "15" Preview 4 installs Xamarin C7 bits.

The next VS "15" public release will install C8 bits.

This is due to major changes in how VS installs extensions in VS "15".

We are working on enabling back support to freely move between Xamarin builds, but this is not there yet.

That said, if you want to try to install C8 bits in Preview 4, please ping me at VGA at microsoft.com and I can send you a few manual steps that MAY work...

thanks