Bug 44274 - App Crash on windows 10 on launch
Summary: App Crash on windows 10 on launch
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 2.3.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-14 01:07 UTC by Paul Mace
Modified: 2017-06-19 16:38 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Paul Mace 2016-09-14 01:07:06 UTC
Form has one element: a label
Debugger set to WiFi (because it won't attach via usb...but that's a different issue.
App Delegate breakpoint at global::Xamarin.Forms.Forms.Init (); is hit.
App hangs at splash screen on Call to MainPage 

public partial class App : Application
    {
        public App ()
        {
            InitializeComponent ();

            MainPage = new SpinX.MainPage (); 
        }
Never gets to  InitializeComponent ();
        public MainPage ()
        {
            InitializeComponent ();

Debugger says it resolved pending breakpoint at InitializeComponent (); but it never gets hit
App is hosed.
Comment 1 Paul DiPietro [MSFT] 2016-09-14 14:35:56 UTC
A reproduction would be needed here as we can't do very much with the information provided.
Comment 2 Paul Mace 2016-09-14 18:55:48 UTC
SO....

Apple releases IOS10

Xamarin developer reports  Forms app dying swifty and suddenly only on IOS10

Xamarin releases New Stable release in the morning...then releases a brand new Forms package late in the day that for some reason was not in the morning stable release.

Apps stop crashing. (Oh, there are still problems with this release, but at least they are debuggable).

Somebody at Xamarin knew Forms .127 was critical for IOS 10 but apparently not you or whoever flipped  the switch on the stable release.

Developer pissed at day wasted, pissed at Xamarin, pissed at routine support brushoff.

I suggest you mention this to your boss.

Paul Mace
Comment 3 Paul DiPietro [MSFT] 2016-09-14 19:48:54 UTC
I asked for a reproduction as I'd like to try and run it on my end. If I create a brand new app with the latest stable version, it runs on my machine running Windows 10. What are you trying to run the app on, and what specific version? Is this with any new project?
Comment 4 Chris Hardy [MSFT] 2017-06-19 16:38:00 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!