Bug 4426 - Quartz sample throws NRE when switching from Blending to another view on device
Summary: Quartz sample throws NRE when switching from Blending to another view on device
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-04-13 13:03 UTC by PJ
Modified: 2012-04-21 03:36 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot (154.00 KB, image/png)
2012-04-13 20:09 UTC, Sebastien Pouliot
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description PJ 2012-04-13 13:03:26 UTC
Steps to reproduce:
1 Debug Quartz sample on iOS device
2 Select [Blending]
3 Select <MonoTouch Quartz Demo] to return to the list of features
4 Select another menu item.

Expected behavior:
Other feature should open

Actual behavior:
Crash: https://gist.github.com/2378311

This issue occurs on Release and Debug.
This issue only occurs on device (not simulator)

Found on:
MT 5.3.3
MD 2.8.8.4
Mono 2.10.9

iPad2 (iOS 5.1)
Comment 1 Sebastien Pouliot 2012-04-13 19:29:49 UTC
This also happens (on an iPod Touch 4th gen) when the linker is disabled.
Comment 2 Sebastien Pouliot 2012-04-13 20:09:52 UTC
Created attachment 1667 [details]
screenshot

It could be a registration bug* since the crash occurs in a method of another type. See screenshot -> that's the wrong `ViewDidLoad`

Also I get weird results (I do not see the picker) if I use another items first (before trying Blending).

* That also differs from simulator and devices.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2012-04-17 19:36:29 UTC
Fixed in master (0c4a1662). Unit tests included.

It's only a regression in master, so nothing has been backported to 5.2.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2012-04-21 03:36:25 UTC
*** Bug 4574 has been marked as a duplicate of this bug. ***