Bug 44152 - Lost Event Trigger Footprint
Summary: Lost Event Trigger Footprint
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.1
Hardware: Other Other
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-09 18:19 UTC by mwg@thoughts.net
Modified: 2016-10-06 02:21 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Procedure (317.98 KB, application/zip)
2016-09-26 14:02 UTC, mwg@thoughts.net
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description mwg@thoughts.net 2016-09-09 18:19:02 UTC
I have a single cross platform XF view with a 9 row x 1 column grid. The planned user experience is have the user respond to a top - down query, one row appearing at a time, the content driven by the previous rows' input. The input controls per row vary. The first row is a single row grid of buttons. The second row is a list view in a grid. The third and forth row is again buttons; however, the forth row is either a single row grid or a three row grid of buttons based on the selection in the third row.

On WinPhone 8.1 and Droid, things are fine through out the 9 nine row sequence. However on iOS, the buttons on the forth row don't work; the "Clicked" event is not firing. The first row buttons fire and make the second row visible. The second row list view gets its event and makes the third row visible. Similarly, the third row buttons makes the forth row appear. When the forth row appears with a single row sub-grid things are OK; however if the three row grid is displayed the buttons are non-responsive.

I had some issues earlier which forced me to move the setting of "Clicked" attribute from the XAML to code immediately before making visible to resolve issues with the single rows. That didn't solve this scenario.
Comment 1 Paul DiPietro [MSFT] 2016-09-12 15:51:50 UTC
Could you attach a reproduction?
Comment 2 mwg@thoughts.net 2016-09-13 02:18:41 UTC
Please clarify what you mean by a reproduction?
Comment 3 Paul DiPietro [MSFT] 2016-09-13 02:41:00 UTC
A runnable project/sample app with code displaying the issue.
Comment 4 mwg@thoughts.net 2016-09-26 14:02:05 UTC
Created attachment 17746 [details]
Test Procedure
Comment 5 mwg@thoughts.net 2016-09-26 14:44:50 UTC
Please use this link to download the code sample demonstrating the issue: 

http://public.thoughts.net/Downloads/Sentry.zip

Feel free to contact me as needed: 443-562-6482
Comment 6 mwg@thoughts.net 2016-09-29 02:09:01 UTC
Code available with test procedure.