Bug 44147 - Xocde 8 / Xamarin.MacDev.HostingException: Could not load the framework 'IDEFoundation'
Summary: Xocde 8 / Xamarin.MacDev.HostingException: Could not load the framework 'IDEF...
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: General ()
Version: 0.34.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Rodrigo Moya
URL:
Depends on:
Blocks:
 
Reported: 2016-09-09 16:45 UTC by RobertN
Modified: 2016-09-20 05:31 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description RobertN 2016-09-09 16:45:17 UTC
Profiler Version 0.34.0-36

Opening "Xamarin Profiler" via Spotlight / Finder results in no running application, no errors logged in Console.app

Opening via cmd-line:


   /Applications/Xamarin\ Profiler.app/Contents/MacOS/Xamarin\ Profiler

Results in:


	ERROR [2016-09-09 09:35:30Z]: uncaught exception
	Xamarin.MacDev.HostingException: 
	Could not load the framework 'IDEFoundation' (path: /Applications/Xcode.app/Contents/Developer/../Frameworks/IDEFoundation.framework/IDEFoundation): 
	dlopen(/Applications/Xcode.app/Contents/Developer/../Frameworks/IDEFoundation.framework/IDEFoundation, 1): 
	Library not loaded: @rpath/DVTAnalytics.framework/Versions/A/DVTAnalytics
	  Referenced from: /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/Versions/A/IDEFoundation
	  Reason: image not found
	  at Xamarin.MacDev.MacServices.LoadFramework (System.String framework) [0x0007a] in /Users/~~~~/maciostools/Xamarin.MacDev.Ide/MacServices.cs:140
  
Environment:

OS-X 10.11.6
Xcode 8.0 Build version 8A218a
Mono 4.6.0 (mono-4.6.0-branch/dea2155) (64-bit)
Xamarin Profiler 0.34.0-36
Xamarin Studio Community Version 6.1 (build 5436)
Xamarin.iOS Version: 10.0.0.4 (Xamarin Studio Community) Hash: d1ee3ba Branch: xcode8 Build date: 2016-09-08 02:32:05-0400
Apple SDK : SDK found in default location (/Applications/Xcode.app)
Comment 1 xamarin-release-manager 2016-09-13 09:49:15 UTC
Fixed in version 0.34.1.1 (cycle7)

Author: Rodrigo Moya
Commit: 0fa21cf86b241cbd85fefe808dfba42eda163027 (xamarin/profiler)
Comment 2 asimk 2016-09-15 16:26:58 UTC
I have checked this issue with latest profiler build i.e. 0.34.2.4 and observed that I am able to open Xamarin Profiler via Finder.
Screencast: http://www.screencast.com/t/iXUI2jIvd2n

But I am unable to launch Xamarin Profiler via command line-> /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

@RobertN, Could you please check that command-> /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler is works for you?
Comment 3 asimk 2016-09-16 13:39:59 UTC
I have checked this again and now its works for me. Earlier I was doing something wrong.
Screencast: http://www.screencast.com/t/T4mF5nzZWX
Hence closing this issue.
Comment 4 Roy Cornelissen 2016-09-20 05:31:53 UTC
Where can we find the newer build of the Profiler? As mentioned in this thread http://forums.xamarin.com/discussion/77869/where-can-i-download-xamarin-profiler-version-0-34-1-1-or-0-34-2-4#latest, 0.33 is incompatible with Cycle 8 and the current version 0.34.1 crashes on startup with the error mentioned above.

ERROR [2016-09-20 07:29:51Z]: uncaught exception
Xamarin.MacDev.HostingException: Could not load the framework 'IDEFoundation' (path: /Applications/Xcode.app/Contents/Developer/../Frameworks/IDEFoundation.framework/IDEFoundation): dlopen(/Applications/Xcode.app/Contents/Developer/../Frameworks/IDEFoundation.framework/IDEFoundation, 1): Library not loaded: @rpath/DVTAnalytics.framework/Versions/A/DVTAnalytics
  Referenced from: /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/Versions/A/IDEFoundation
  Reason: image not found
  at Xamarin.MacDev.MacServices.LoadFramework (System.String framework) [0x0007a] in /Users/builder/data/lanes/3460/95785b77/source/profiler/external/maciostools/Xamarin.MacDev.Ide/MacServices.cs:140 
  at Xamarin.MacDev.MacServices.LoadFrameworks () [0x000dd] in /Users/builder/data/lanes/3460/95785b77/source/profiler/external/maciostools/Xamarin.MacDev.Ide/MacServices.cs:71 
  at Xamarin.MacDev.MacServices.Initialize (Boolean enable_xcode_plugins) [0x00063] in /Users/builder/data/lanes/3460/95785b77/source/profiler/external/maciostools/Xamarin.MacDev.Ide/MacServices.cs:42 
  at XamarinProfiler.Core.Platforms.iOS.PlatformIos..ctor () [0x00030] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Core/Platforms/iOS/PlatformIos.cs:34 
  at XamarinProfiler.Core.Platform.get_ProfilingPlatforms () [0x0002a] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Core/Platform.cs:105 
  at XamarinProfiler.Core.ProfilerSession.Initialize (XamarinProfiler.Core.RunFactory runFactory) [0x0000d] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Core/ProfilerSession.cs:33 
  at XamarinProfiler.Mac.MainClass.Main (System.String[] args) [0x00032] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Mac/Main.cs:29 
[ERROR] FATAL UNHANDLED EXCEPTION: Xamarin.MacDev.HostingException: Could not load the framework 'IDEFoundation' (path: /Applications/Xcode.app/Contents/Developer/../Frameworks/IDEFoundation.framework/IDEFoundation): dlopen(/Applications/Xcode.app/Contents/Developer/../Frameworks/IDEFoundation.framework/IDEFoundation, 1): Library not loaded: @rpath/DVTAnalytics.framework/Versions/A/DVTAnalytics
  Referenced from: /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/Versions/A/IDEFoundation
  Reason: image not found
  at Xamarin.MacDev.MacServices.LoadFramework (System.String framework) [0x0007a] in /Users/builder/data/lanes/3460/95785b77/source/profiler/external/maciostools/Xamarin.MacDev.Ide/MacServices.cs:140 
  at Xamarin.MacDev.MacServices.LoadFrameworks () [0x000dd] in /Users/builder/data/lanes/3460/95785b77/source/profiler/external/maciostools/Xamarin.MacDev.Ide/MacServices.cs:71 
  at Xamarin.MacDev.MacServices.Initialize (Boolean enable_xcode_plugins) [0x00063] in /Users/builder/data/lanes/3460/95785b77/source/profiler/external/maciostools/Xamarin.MacDev.Ide/MacServices.cs:42 
  at XamarinProfiler.Core.Platforms.iOS.PlatformIos..ctor () [0x00030] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Core/Platforms/iOS/PlatformIos.cs:34 
  at XamarinProfiler.Core.Platform.get_ProfilingPlatforms () [0x0002a] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Core/Platform.cs:105 
  at XamarinProfiler.Core.ProfilerSession.Initialize (XamarinProfiler.Core.RunFactory runFactory) [0x0000d] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Core/ProfilerSession.cs:33 
  at XamarinProfiler.Mac.MainClass.Main (System.String[] args) [0x00032] in /Users/builder/data/lanes/3460/95785b77/source/profiler/src/XamarinProfiler.Mac/Main.cs:29 
 
Thanks!