Bug 44106 - [UWP] ListView group jumplist not updated when adding new items
Summary: [UWP] ListView group jumplist not updated when adding new items
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-08 12:01 UTC by Serge
Modified: 2017-05-30 02:12 UTC (History)
4 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample to reproduce (74.70 KB, application/x-zip-compressed)
2016-09-08 12:01 UTC, Serge
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 44106 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Serge 2016-09-08 12:01:11 UTC
Created attachment 17376 [details]
Sample to reproduce

For grouped ListView, jumplist only initialized and not updated when adding new items.

Steps to reproduce:
1. run sample in attachement
2. tap on group header -> jumplist opens with one group as expected
3. press back button to close jumplist
4. press "add" item in the toobar to add new group
5. tap on group header -> only initial group exists in jumplist
Comment 1 Lee McPherson 2017-02-13 02:09:17 UTC
This also happens very easily in the ControlGallery.  Scroll down to GroupedList Gallery - Legacy and try to change the sorting to Last Name.  The jumplist won't update.  YouTube video showing same behavior:
https://youtu.be/RBP83UHZBPk