Bug 4406 - Debugger tooltip does not show up correctly
Summary: Debugger tooltip does not show up correctly
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-04-12 11:21 UTC by Alan McGovern
Modified: 2012-04-13 16:26 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alan McGovern 2012-04-12 11:21:28 UTC
1) Debug code like the following:

var xx = GetFoo ();
console.Writeline (xx.ToString ());

if you hover the mouse on the declaration of 'xx' in the first line, you do not get the debugger tooltip showing the value of 'xx', you get displayed a regular code completion tooltip.

If you hover over the usage of 'xx' in the Console.WriteLine, the debugger tooltip displays and i can see if xx is null, or if it is not i can see the values of its fields.

See screencast if that description is confusing: http://screencast.com/t/ldrI0UqyHQ7
Comment 1 Jeffrey Stedfast 2012-04-12 16:13:20 UTC
fixed in git master
Comment 2 Alan McGovern 2012-04-13 06:58:40 UTC
I only get tooltips for enum types now. See video for more info:

http://screencast.com/t/qktcR5Fack9
Comment 3 Jeffrey Stedfast 2012-04-13 16:26:42 UTC
this should be fixed now