Bug 44005 - The installed Xamarin.iOS (version 9.8) on the Mac is not compatible with the local Xamarin.iOS 9.99
Summary: The installed Xamarin.iOS (version 9.8) on the Mac is not compatible with the...
Status: RESOLVED DUPLICATE of bug 43926
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-06 04:09 UTC by Jon Douglas [MSFT]
Modified: 2016-09-06 15:30 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE log describing the issue (4.99 KB, text/plain)
2016-09-06 04:09 UTC, Jon Douglas [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 43926

Description Jon Douglas [MSFT] 2016-09-06 04:09:21 UTC
Created attachment 17336 [details]
IDE log describing the issue

*Description:

It seems that when there is a mismatch of Xamarin.iOS Versions between the Mac and Windows(VS), there is not a warning in Visual Studio 2015, but it will crash the IDE instead with the following log entry:

```
The installed Xamarin.iOS (version 9.8) on the Mac Jons-MacBook-Pro.local (192.168.1.12) is not compatible with the local Xamarin.iOS 9.99.
```

This is definitely less than ideal as it should not crash the IDE and should rather give an error in the "Error List" tab and point the user to their IDE logs to discover this error.

I am able to reproduce this when having the Windows Version at Xamarin.iOS 9.99.5.54(Current Beta) and the Mac on Xamarin.iOS 9.8.2.22(Current Stable)

*Version Information

Microsoft Visual Studio Professional 2015
Version 14.0.25421.03 Update 3
Microsoft .NET Framework
Version 4.6.01038

Installed Version: Professional

Xamarin   4.2.0.628 (f4d4600)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.0.3 (89d9d60)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   9.99.5.54 (974ea0b)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 1 Ben Beckley 2016-09-06 15:30:37 UTC

*** This bug has been marked as a duplicate of bug 43926 ***