Bug 43998 - Xamarin.Forms.Maps.Map not working in ListView.
Summary: Xamarin.Forms.Maps.Map not working in ListView.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-05 16:42 UTC by DanDev
Modified: 2016-09-05 18:10 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description DanDev 2016-09-05 16:42:06 UTC
When I use a Map control inside my ListView cell, the location of the map is stuck at the middle of the earth. If I have the Map as child of the ContentPage (outside any templates) the location will be correct.

XAML:
http://pastebin.com/raw/0ZQSMpWP
Map Control:
http://pastebin.com/raw/m4QC0pAF
Comment 1 DanDev 2016-09-05 18:10:08 UTC
Moving the ListView tag inside the AbsoluteLayout tag somehow fixed this.