Bug 43959 - [VS 2012, VS 2013] "Tools > iOS > Device Log..." menu item is _not_ disabled until an iOS project is loaded
Summary: [VS 2012, VS 2013] "Tools > iOS > Device Log..." menu item is _not_ disabled ...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- minor
Target Milestone: 4.3.0 (C9)
Assignee: Adrian Alonso
URL:
Depends on: 43957
Blocks:
  Show dependency tree
 
Reported: 2016-09-01 22:10 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-12-27 05:38 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: No
Last known good build:


Attachments
Screen capture of the behavior of "Device Log..." in VS 2013 (533.09 KB, application/x-shockwave-flash)
2016-09-01 22:10 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-09-01 22:10:09 UTC
Created attachment 17308 [details]
Screen capture of the behavior of "Device Log..." in VS 2013

[VS 2012, VS 2013] "Tools > iOS > Device Log..." menu item is _not_ disabled until an iOS project is loaded




## Regression status: not a regression, but it is a _new_ behavior of new feature




## Steps to replicate

1. Install Xamarin Cycle 8 on Windows.

2. Open Visual Studio 2012 or Visual Studio 2013 (tested with VS 2013 Update 3).

3. Do _not_ open any projects.  (In particular, do not open any iOS projects.)

4. Click the "TOOLS" menu and navigate to "iOS".




## Results

- The "Device Log..." entry is displayed and is _not_ disabled.


- Clicking the entry causes a spinner to appear for a while.  But then eventually the only thing that happens is that the "Output" window switches views to show the "Xamarin" section.

(See attached screen capture.)


- After the "Output" window switches to show the "Xamarin" section, the "Device Log..." menu item then _does_ become disabled.




## Possible improvements

Ensure the "Device Log..." entry is always disabled in VS 2012 and VS 2013.

Depending on how Bug 43957 gets addressed, this secondary bug might become irrelevant (for example if the menu entry is simply removed entirely).




## Version info (brief)

Visual Studio Professional 2013 Update 3
XamarinVS 4.2.0.628-cycle8+f4d4600
Windows 8.1 (64-bit)
Comment 1 Adrian Alonso 2016-12-20 18:30:15 UTC
This should be already resolved in C9 since the DeviceLog feature should not be included at all in the final extension bundle if  VS < dev14. If you can still see the command please let know.
Comment 3 Mohit Kheterpal 2016-12-22 15:33:34 UTC
I have checked this issue with latest build of C9 i.e. XVS 4.3.0.497 _ 526a008aede9e857a169ac2d0e1411a30d746c87 on lane 'xvs-win-cycle9' and observed that this issue still exist as shown in screencast : https://www.screencast.com/t/cvLaGZvb9quv

I have checked it with C8 build i.e. 4.2.2.5 and observed the same behaviour as I have mentioned in screencast.

As of now I am reopening this issue, please let me know with which build version of C9 this issue has been fixed.

thanks
Comment 4 Jose Gallardo 2016-12-26 18:45:00 UTC
Please verify again, as this was fixed in 4.3.0.501.
Thanks!
Comment 5 Danish Akhtar 2016-12-27 05:38:58 UTC
I have checked this issue with C9 XVS 4.3.0.501 and with master XVS 99.1.0.392 and observed that now Device log option is removed from VS 2013. Here is the screencast for the same: https://www.screencast.com/t/Vj43DMMrKJj

Hence closing this issue.