Bug 43898 - Navigation Bar issue with Xamarin.Forms and iOS 10
Summary: Navigation Bar issue with Xamarin.Forms and iOS 10
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-31 14:17 UTC by Don Dauphinee
Modified: 2016-09-19 19:20 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Don Dauphinee 2016-08-31 14:17:15 UTC
I've run into an issue using Xamarin.Forms and running the app in iOS 10. It seems as soon as the top Navigation bar is shown in the UI, the entire screen shifts up at the exact height of the Navigation bar. So there is a blank space on the bottom of the screen equal to the height of the nav bar, and the top part of the content page is now hidden behind the nav bar. If there is no nav bar - the UI displays fine.

You can see it doing this in the MyShoppe sample app as well, so I think something has changed with the UI behavior from iOS 9 to 10, and something needs to be fixed on the Xamarin side.

I've even downloaded the Beta Xcode, and Xamarin installs on the Mac and the PC running Visual Studio hoping there would be a fix, but I got the same result.
Comment 1 Jonathan Horvath 2016-09-09 13:52:28 UTC
Our application is experiencing the exact issue described above. The application is unusable in iOS 10 because of the bug. Please bump the importance to high.
Comment 2 Don Dauphinee 2016-09-09 14:10:13 UTC
Thanks Jonathan, good to know I'm not the only one with the issue - hopefully Xamarin can recreate the issue and provide a fix within the next week. Or at least some kind of code workaround to correct the formatting. It seems only Xamarin has the ability to bump the importance of the bug - I am hoping they recognize the severity.
Comment 3 doug.mcclung 2016-09-15 18:42:48 UTC
We have the same issue.  Has anyone heard any updates on a fix or any work arounds?
Comment 4 Chris Blair 2016-09-16 20:22:09 UTC
We have the same issue.  Any workarounds yet?
Comment 5 doug.mcclung 2016-09-16 21:22:30 UTC
We are testing padding our master and detail pages down the width of the nav bar if we identify the device as an iPhone running iOS 10.  Something like:
if (Device.OS == TargetPlatform.iOS && Constants.GetOSMajorVersionNumber() >= 10)
                     {
                           Padding = new Thickness(0, 60, 0, 0);
                     }
Comment 6 Devender 2016-09-17 10:56:52 UTC
We had the same issue throughout our app(after iOS 10 update) with Xamarin.Forms 1.4.0.xxxx. Today we updated with XF version 2.0.0.6482 and this issue is no more now. Not checked with higher XF versions.
Comment 7 Don Dauphinee 2016-09-19 19:19:57 UTC
Thank you - this seems to have fixed our problems. We had thought we were up to date with everything because the Xamarin updater said we were - however, it looks like Xamarin.Forms isn't part of this.