Bug 43808 - Breadcrumb templates show up with XamarinVS installed
Summary: Breadcrumb templates show up with XamarinVS installed
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: 4.2.1 (C8SR1)
Assignee: vga
URL:
Depends on:
Blocks:
 
Reported: 2016-08-27 15:12 UTC by vga
Modified: 2016-10-06 13:17 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: C7 builds

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 xamarin-release-manager 2016-08-28 00:22:11 UTC
Fixed in version 99.0.0.3490 (master)

Author: victorgarciaaprea
Commit: 3b8978105d63fd0ab8722f4bbf2744367077ba15 (xamarin/XamarinVS)
Comment 2 xamarin-release-manager 2016-08-30 14:03:26 UTC
Fixed in version 4.2.0.620 (cycle8)

Author: Jose Gallardo
Commit: 227b067a03530f56d5793dad03f0bf38a7ec138f (xamarin/XamarinVS)
Comment 4 Sunil Kumar 2016-10-05 16:39:09 UTC
I have checked this issue with latest Master Xamarin.VisualStudio_99.0.0.3900_f15e2c4d1fe3868ca3eb088c82c27834a7792fc5 and observed that now this issue is working fine. Now Android breadcrumb template is not displaying in template list while XVS is installed on the machine. 

Screencast: http://www.screencast.com/t/tiYAWtFkLtqt

Android breadcrumb template is displaying in template list only when XVS is not installed on the machine as shown in screencast: http://www.screencast.com/t/hW2tb1r6UP

Environment info:
Microsoft Visual Studio Enterprise 2015
Version 14.0.25424.00 Update 3
Microsoft .NET Framework
Version 4.6.01055

Xamarin   99.0.0.3900 (f15e2c4)
Xamarin Inspector Support   0.8.1.15 (dbf88f5)
Xamarin.Android   7.0.99.101 (c6ba8f2)
Xamarin.iOS   10.1.0.98 (1d828e9)

I'll verify this issue once get this fix in C8SR1.
Comment 5 Sunil Kumar 2016-10-06 11:56:54 UTC
I have checked this issue with C8 Xamarin.VisualStudio_4.2.0.718_650faa5b0c4197b1c46b75e77e6e7d591db0f4de and observed that this issue is working fine. Now Android breadcrumb template is not displaying in template list while XVS is installed on the machine. 

Screencast: http://www.screencast.com/t/cHolmiJhd

Environment info:
Microsoft Visual Studio Enterprise 2015
Version 14.0.25424.00 Update 3
Microsoft .NET Framework
Version 4.6.01055

Xamarin   4.2.0.718 (650faa5)
Xamarin Inspector Support   0.8.1.15 (dbf88f5)
Xamarin.Android   7.0.0.19 (7b76cb8)
Xamarin.iOS   10.0.1.10 (191f81a)

I'll verify this issue once fix will merge in C8SR1.
Comment 6 Sunil Kumar 2016-10-06 13:17:01 UTC
As per comment 4 and comment 5, this issue is working fine with Master and C8 build, hence I am closing this issue.

Thanks!