Bug 43747 - Socket.ConnectAsync does not set Socket.RemoteEndpoint
Summary: Socket.ConnectAsync does not set Socket.RemoteEndpoint
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 4.4.2 (C7SR1)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: marcos.henrich
URL:
Depends on:
Blocks:
 
Reported: 2016-08-25 14:26 UTC by NicolasDorier
Modified: 2017-09-08 23:30 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Source code replicating the bug (802 bytes, text/plain)
2016-08-25 14:26 UTC, NicolasDorier
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description NicolasDorier 2016-08-25 14:26:23 UTC
Created attachment 17214 [details]
Source code replicating the bug

Repro:

-Call Socket.ConnectAsync(SocketAsyncEventArgs),
-Once connected, check Socket.RemoteEndpoint,

Result:

-Socket.RemoteEndpoint is null

Expected:

-Socket.RemoteEndpoint should be filled with SocketAsyncEventArgs.RemoteEndpoint (behavior in .NET 4.5)

See attachment for repro.
Comment 1 NicolasDorier 2016-08-25 15:27:31 UTC
Comment on attachment 17214 [details]
Source code replicating the bug

On Mono returns true, else return false.
Comment 2 Marek Safar 2017-09-08 23:30:16 UTC
Already fixed in master