Bug 43721 - WCF Service fails to initialize when using iOS 10 Beta
Summary: WCF Service fails to initialize when using iOS 10 Beta
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: BCL Class Libraries ()
Version: XI 9.99 (iOS 10 previews)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Alexander Köplinger [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-08-24 20:30 UTC by Cody Beyer (MSFT)
Modified: 2016-09-26 20:53 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Cody Beyer (MSFT) 2016-08-24 20:30:12 UTC
# Error Details

>System.TypeInitializationException: The type initializer for 'System.ServiceModel.ClientBase`1' threw an >exception. ---> System.NotImplementedException: The method or operation is not implemented.
>  at System.ServiceModel.InstanceContext..ctor (System.Object implementation) [0x00006] in >/Users/builder/data/lanes/3426/9eca8766/source/xamarin-macios/_ios->build/Library/Frameworks/Xamarin.iOS.framework/Versions/git/src/mono/mcs/class/System.ServiceModel/Dummy_2_1.cs:50
>  at System.ServiceModel.ClientBase`1[TChannel]..cctor () [0x00000] in >/Users/builder/data/lanes/3426/9eca8766/source/xamarin-macios/_ios->build/Library/Frameworks/Xamarin.iOS.framework/Versions/git/src/mono/mcs/class/System.ServiceModel/System.Service>Model/ClientBase.cs:45
>  --- End of inner exception stack trace ---
>  at at (wrapper managed-to-native) UIKit.UIApplication:UIApplicationMain (int,string[],intptr,intptr)
>  at UIKit.UIApplication.Main (System.String[] args, System.IntPtr principal, System.IntPtr delegate) [0x00005] >in /Users/builder/data/lanes/3426/9eca8766/source/xamarin-macios/src/UIKit/UIApplication.cs:79
>  at UIKit.UIApplication.Main (System.String[] args, System.String principalClassName, System.String >delegateClassName) 

# Sample

https://github.com/xamarin/xamarin-forms-samples/tree/master/WebServices/TodoWCF

# Steps to Reproduce

	1. Download Sample
	2. Deploy to iOS Device or Simulator

# Expected Results

To Do app runs

# Actual Results

Error thrown

# Versions

=== Xamarin Studio Business ===

Version 6.1 (build 5345)
Installation UUID: 9d0d22a4-94e4-4a24-802e-d794f948732d
Runtime:
	Mono 4.6.0 (mono-4.6.0-branch/d0fc1a6) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 406000150

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.0 (11239.2)
Build 8S201h

=== Xamarin.Mac ===

Version: 2.10.0.65 (Xamarin Business)

=== Xamarin.iOS ===

Version: 9.99.3.8 (Xamarin Business)
Hash: 9eca876
Branch: cycle8
Build date: 2016-08-16 18:22:42-0400

=== Xamarin.Android ===

Version: 6.2.0.36 (Xamarin Business)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		6.0 (API level 23)

SDK Tools Version: 25.1.2
SDK Platform Tools Version: 24.0.0
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 601005345
Git revision: fc3ab7c0cc891ef8c9867558d026257fc4654758
Build date: 2016-08-16 18:26:59-04
Xamarin addins: 695f42de8ea790cc717ccd388f2becfa35e704ae
Build lane: monodevelop-lion-cycle8

=== Operating System ===

Mac OS X 10.11.6
Darwin clb-mbook.local 15.6.0 Darwin Kernel Version 15.6.0
    Thu Jun 23 18:25:34 PDT 2016
    root:xnu-3248.60.10~1/RELEASE_X86_64 x86_64
Comment 1 Alexander Köplinger [MSFT] 2016-08-24 21:24:49 UTC
This was fixed in Mono with https://github.com/mono/mono/commit/da0255c3e0bd9713ebbe23e08a5fb637c9c34e71 and should   be in the XI C8 Beta2 release we just pushed.