Bug 43709 - The 'System.Reactive 3.0.0' package requires NuGet client version '2.12' or above...
Summary: The 'System.Reactive 3.0.0' package requires NuGet client version '2.12' or a...
Status: VERIFIED FIXED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Cross Platform (Shared Code) ()
Version: 0.9.0
Hardware: PC Windows
: --- normal
Target Milestone: 1.0
Assignee: xamarininteractive
URL:
Depends on:
Blocks:
 
Reported: 2016-08-24 17:24 UTC by Antao Almada
Modified: 2016-10-24 16:18 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Antao Almada 2016-08-24 17:24:14 UTC
Version 0.10.0 but there's no option here...

To reproduce: Create a WPF workbook and add the 'System.Reactive 3.0.0' package.
Comment 1 Sandy Armstrong [MSFT] 2016-08-24 17:32:40 UTC
Thanks, we'll bump the nuget library we use.
Comment 2 Sandy Armstrong [MSFT] 2016-10-20 21:58:51 UTC
This package still has issues, but our upcoming release has bumped nuget to 2.12, so closing this bug.
Comment 3 Rajneesh Kumar 2016-10-24 14:23:34 UTC
Hi  I have checked this issue with Nuget Version: 3.4.3.0 and with XamarinInteractive-0.10.0.747 and observed that I am not able to add System.Reactive 3.0.0' package to the WPF application.

Screencast: http://www.screencast.com/t/9CS97ZNZ317

Please have a look and let me know that what I am missing to check it.

Thanks..!
Comment 4 Rajneesh Kumar 2016-10-24 16:18:03 UTC
As per discussion with @Sandy Armstrong that package doesn't work at this time. but the specific error the user reported has been fixed. Hence I am closing this issue.

Thanks..!