Bug 43702 - Updated to Xamarin Studio cycle 8 beta -- try to build the project and get error with @(None) for the Info.plist file
Summary: Updated to Xamarin Studio cycle 8 beta -- try to build the project and get er...
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 9.99 (iOS 10 previews)
Hardware: Macintosh Mac OS
: --- blocker
Target Milestone: 10.0.0 (C8)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-24 13:47 UTC by Fokke Vermeulen
Modified: 2016-08-29 14:51 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Fokke Vermeulen 2016-08-24 13:47:40 UTC
# Steps to reproduce
Update form cycle 7 to cycle 8
Build the pcl-project. 


/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Error executing task FindItemWithLogicalName: Error converting Property named 'Items' with value '@(None)' to type Microsoft.Build.Framework.ITaskItem[]: Unsupported type: Microsoft.Build.Framework.ITaskItem (CompanyApp.iOS)

# Supplemental info (logs, images, videos)

in the iOS.csproj-file it stands like this:

<ItemGroup>
    <None Include="Entitlements.plist" />
    <None Include="packages.config" />
    <None Include="Info.plist" />
  </ItemGroup>


# Test environment (full version information)
=== Xamarin Studio Professional ===

Version 6.1 (build 5345)
Runtime:
	Mono 4.6.0 (mono-4.6.0-branch/d0fc1a6) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 406000150

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 6.2.0.36 (Visual Studio Professional)
Android SDK: /Users/fvermeulen/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3  (API level 15)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 25.1.7
SDK Platform Tools Version: 24.0.1
SDK Build Tools Version: 24.0.1

Java SDK: /usr
java version "1.8.0_92"
Java(TM) SE Runtime Environment (build 1.8.0_92-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.92-b14, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.3.1 (10188.1)
Build 7D1014

=== Xamarin.Mac ===

Version: 2.10.0.65 (Visual Studio Professional)

=== Xamarin.iOS ===

Version: 9.99.3.8 (Visual Studio Professional)
Hash: 9eca876
Branch: cycle8
Build date: 2016-08-16 18:22:42-0400

=== Build Information ===

Release ID: 601005345
Git revision: fc3ab7c0cc891ef8c9867558d026257fc4654758
Build date: 2016-08-16 18:26:59-04
Xamarin addins: 695f42de8ea790cc717ccd388f2becfa35e704ae
Build lane: monodevelop-lion-cycle8

=== Operating System ===

Mac OS X 10.11.6

=== Enabled user installed addins ===

NuGet Package Management Extensions 0.11.1
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2016-08-25 02:57:19 UTC
Thanks for the report!  To help the Xamarin team address this issue as efficiently as possible, please provide additional information, such as:


- Do you get the same problem on a new template "iOS > App > Single View App" that references a new template "Multiplatform > Library > Portable Library"?  I was unable to replicate an error using that setup in my initial testing.


- If at all possible, please attach a small, self-contained test case that reproduces the bug with as little code as possible.


- Please collect and attach the diagnostic MSBuild output [1] for the failing build.

[1] See "verbose build output" on https://kb.xamarin.com/customer/en/portal/articles/1675684#verbose-build-output-logs



See https://kb.xamarin.com/customer/en/portal/articles/1910343 for additional details about what to include and some strategies for minimizing test cases.  Thanks in advance!
Comment 2 Fokke Vermeulen 2016-08-29 14:51:40 UTC
I think it is gone with updating the xamarin studio to the latest beta version, or it fixed itself over the night. I don't know. 

Didn't get the problem since thursday.