Bug 43542 - NSOpenGLLayer is missing
Summary: NSOpenGLLayer is missing
Status: RESOLVED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: Master
Hardware: PC Other
: --- normal
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2016-08-19 15:42 UTC by Matthew Leibowitz
Modified: 2016-09-13 22:00 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 Chris Hamons 2016-08-26 16:47:38 UTC
https://github.com/xamarin/xamarin-macios/pull/684
Comment 2 Chris Hamons 2016-08-26 20:47:57 UTC
Fixed in xcode8 branch.
Comment 3 Matthew Leibowitz 2016-09-08 19:52:42 UTC
Will this make it into the C8 release?
Comment 4 Chris Hamons 2016-09-13 22:00:45 UTC
Yes and no. It landed in the xcode8 branch so it won't be in the first C8 release (today).

However, next week we'll push to the beta channel the xcode8 bits for XM and it'll be there.

Until Apple makes a final 10.12 we can't release XM xcode8, and unless I cherry pick these separate, they are tagging along there.