Bug 43248 - unable to launch the iOS simulator from visual studio
Summary: unable to launch the iOS simulator from visual studio
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-10 19:21 UTC by reemfz
Modified: 2016-12-22 19:26 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
attempting to launch the simulator (215.25 KB, image/png)
2016-08-10 19:21 UTC, reemfz
Details
log files from xamarin (PC) (36.21 KB, application/x-zip-compressed)
2016-08-10 22:48 UTC, reemfz
Details
log files from xamarin (Mac) (114.97 KB, application/x-zip-compressed)
2016-08-10 22:48 UTC, reemfz
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description reemfz 2016-08-10 19:21:20 UTC
Created attachment 16975 [details]
attempting to launch the simulator

Hello,

every once in a while, when I try to run the app in the simulator, I click on the Run button, but nothing happens, except a short message is being printed out to the output window (see screenshot).
Rebuilding the solution or project does not fix the issue.
the only work around I found was to restart visual studio. Then it works.

Steps to reproduce:

1. open a Xamarin.iOS project. 
2 Select the iphone simulator and then select the simulator version.
3.Click on the run button.

*** This issue does not occur all the time

Let me know if you need more info.

Hopefully it was fixed in c8

thanks,
Comment 1 Ben Beckley 2016-08-10 21:27:49 UTC
Hello,

If you encounter this again, please provide the log file from the Windows machine that is located here: 
>C:\Users\Username\AppData\Local\Xamarin\Logs\Xamarin.Simulator\

And to be thorough, please also provide the log from the Mac as well, which can be found here:
>~\Library\Logs\Xamarin\Simulator.Server

Thank you.
Comment 2 reemfz 2016-08-10 22:48:24 UTC
Created attachment 16981 [details]
log files from xamarin (PC)
Comment 3 reemfz 2016-08-10 22:48:52 UTC
Created attachment 16982 [details]
log files from xamarin (Mac)
Comment 4 reemfz 2016-08-10 22:50:38 UTC
Hi Ben,

the paths you provided do not exist on either the PC or the Mac. (maybe they do on a different channel). 
anyhow, I attached all the log files from both the mac and pc 

let me know if you need additional info.

Thanks,
Rob
Comment 5 Eric Maupin 2016-08-11 20:26:31 UTC
If the log paths don't exist, the Windows iOS simulator was never launched by Visual Studio, so redirecting to that product.
Comment 6 reemfz 2016-08-11 22:36:40 UTC
even if the ios simulator was launched by visual studio, I still can't see those folders. 
on windows all I see are 14.0 and DocSync folders

just to be clear, I am referring to the native iOS simulator on the mac, not the new one you guys releases at Evolve.
Comment 7 Adrian Alonso 2016-08-18 18:19:10 UTC
Hi, does it only happen if you try to debug the app? Or also if you Run without debugging? Thanks, Adrian
Comment 8 reemfz 2016-08-19 16:14:03 UTC
that's a good question. I didn't try it.

let me try it when it happens again and I'll update you.
Also, I will try to make a quick screen cast so you can see the behavior.

Thanks,
Comment 9 Adrian Alonso 2016-12-22 19:26:21 UTC
Please let us know if we should make any additional investigation for this issue. Thanks! Adrian