Bug 42998 - Can't launch app extension on macOS 10.12
Summary: Can't launch app extension on macOS 10.12
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Other ()
Version: Master
Hardware: Macintosh Mac OS
: High major
Target Milestone: 2.10.0 (C8)
Assignee: Chris Hamons
URL:
: 43027 ()
Depends on:
Blocks:
 
Reported: 2016-08-02 15:02 UTC by Oleg Demchenko
Modified: 2016-08-08 18:11 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Oleg Demchenko 2016-08-02 15:02:04 UTC
Steps to reproduce:
1) Checkout ExtensionSamples: https://github.com/xamarin/mac-samples/tree/master/ExtensionSamples
2) Build "ExtensionSample" project
3) Run "ShareExtension" item

Actual:
App extension can't be found in System Preferences -> Extensions.

Expected:
App extension should be installed on your machine, it should appear in System Preferences -> Extensions and you should be able to use it in Safari.

Note:  
App extensions are working fine on ElCapitan. The bug can be reproduced only on Sierra with C8/preview/master builds.

Env. details:
https://gist.github.com/olegoid/9216d83423b6c276530b39007bac98f0
Comment 1 Rajneesh Kumar 2016-08-02 16:23:57 UTC
I have checked this issue with the following Cycle 8 builds:
MonoFramework-MDK-4.6.0.125.macos10.xamarin.universal
xamarin.mac-2.10.0.38
XamarinStudio-6.1.0.5298

and successfully able to reproduce this issue. I observed that App extension doesn't appear in System Preferences -> Extensions.

Screencast: http://www.screencast.com/t/dsY9zjyVS

Ide Logs: https://gist.github.com/saurabh360/927ce9fa3dc1164d93fac7ff5a9151f1

Environment Info:

https://gist.github.com/saurabh360/bf91d5a6654ce82ec3293091429c4e6f
Comment 2 Chris Hamons 2016-08-04 14:05:38 UTC
*** Bug 43027 has been marked as a duplicate of this bug. ***
Comment 3 Chris Hamons 2016-08-05 17:27:20 UTC
This has been 'fixed' in XS master by removing the run functionality out of the extension projects.

The new way to run them is:

Add a reference from your extension to the "host" container application.
Build and run it one time.
System Preferences -> Extensions and enable the extension.
Comment 4 Chris Hamons 2016-08-05 17:27:40 UTC
https://github.com/xamarin/md-addins/pull/1170