Bug 42971 - Build warnings on Windows because of Roslyn and .NET 4.5 vs 4.5.2
Summary: Build warnings on Windows because of Roslyn and .NET 4.5 vs 4.5.2
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-02 03:25 UTC by Daniel Cazzulino
Modified: 2017-05-26 15:22 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Comment 1 Alan McGovern 2016-08-29 10:22:45 UTC
What version of the .NET framework is used in VS2012, 2013 and 2015? If we compile against a newer version than we use at runtime we could link against methods/overloads which do not exist under the older framework and crash at runtime under the older VS versions.
Comment 2 Daniel Cazzulino 2016-08-29 14:54:32 UTC
https://github.com/xamarin/XamarinVS/blob/master/src/Setup/Xamarin.VisualStudio/Product.wxs#L19

We require .NET 4.6 installed in our setup. It's safe to use either 4.5.2 or 4.6 as the target framework version.
Comment 3 Daniel Cazzulino 2017-05-26 15:22:54 UTC
Ok, I'm closing this since there's no actionable item for the XVS team.

We are requiring .NET 4.6 on install on all platforms (VS2013+), so it's safe to say that all projects should target 4.6 at a minimum.

Thanks