Bug 42960 - make get-monolite-latest fail because url doesn't work
Summary: make get-monolite-latest fail because url doesn't work
Status: CLOSED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: packaging ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jo Shields
URL:
Depends on:
Blocks:
 
Reported: 2016-08-01 16:29 UTC by julie.taliercio
Modified: 2017-07-12 13:34 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description julie.taliercio 2016-08-01 16:29:21 UTC
Hello ! 

I am sorry if I post in the wrong way  ! I know my request is a possible duplicate of the bug 166687 but I can't find any help about that on the web

I have a VPS on Debian 7 and I want to host an application using apache2 and mono. When I use "make get-monolite-latest" to build I have this report : 

--2016-08-01 18:13:31--  (essai: 1)  http://storage.bos.xamarin.com/mono-dist-master/latest/monolite-110-latest.tar.gz
Connexion vers storage.bos.xamarin.com (storage.bos.xamarin.com)|198.0.162.157|:80...échec: Connexion terminée par expiration du délai d'attente.


I tried to change the version on monolite by 111 , 112 or 113 but the server does not answer. 

Do you have any idea that I can use to build mono with monolite ? Or an other way to host my application on apache2 ? 

Thank you very much for your help !!
Comment 1 Zoltan Varga 2016-08-03 20:30:46 UTC
You are probably using an old mono version, newer versions download from:

--2016-08-03 16:21:28--  http://download.mono-project.com/monolite/monolite-152-latest.tar.gz
Resolving download.mono-project.com... 54.192.36.13, 54.192.36.59, 54.192.36.65, ...
Connecting to download.mono-project.com|54.192.36.13|:80... connected.

You can download up-to-date mono packages from:
http://www.mono-project.com/docs/getting-started/install/linux/#debian-ubuntu-and-derivatives
Comment 2 Jo Shields 2016-08-04 06:59:13 UTC
You only need to use `get-monolite-latest` when building from git (it's already provided with tarballs)

We changed our download server around during the 4.4 development cycle - if you're building a version older than 4.4, you need to cherry-pick this commit, which changes the download server:

https://github.com/mono/mono/commit/3f235544

However, as Zoltan points out, binary packages for Debian exist.
Comment 3 julie.taliercio 2017-07-12 13:34:05 UTC
I am sorry to answer this late ! but thank you very much ! I upgraded my version of Mono and everything works fine now!

THANK YOU !