Bug 42954 - OnAppLinkRequestReceived not called on iOS
Summary: OnAppLinkRequestReceived not called on iOS
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-01 14:47 UTC by Simon Friesenbichler
Modified: 2018-04-24 19:07 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Simon Friesenbichler 2016-08-01 14:47:08 UTC
I registered an url type with my app like this:

<key>CFBundleURLTypes</key>
  <array>
    <dict>
      <key>CFBundleURLName</key>
      <string>some.client.id</string>
      <key>CFBundleURLSchemes</key>
        <array>
        <string>appname</string>
	</array>
        <key>CFBundleURLTypes</key>
        <string>None</string>
    </dict>
  </array>

When I click on a link matching my scheme, iOS asks if I would like to open the url with my app, and the app opens, but the "OnAppLinkRequestReceived" override of the Forms.Application isn't called.

I also tried with the latest Forms preview (2.3.1.113-pre3) and getting the same result.

It does work on Android.
Comment 1 Rui Marinho 2016-08-05 13:59:57 UTC
What's your userActivity.ActivityType ? 

OnAppLinkRequestReceived works normally if you have the correct ActivityType, take a look at the code:

https://github.com/xamarin/Xamarin.Forms/blob/master/Xamarin.Forms.Platform.iOS/FormsApplicationDelegate.cs#L143
Comment 2 Simon Friesenbichler 2016-08-08 07:51:20 UTC
Thanks for coming back to me.

I already had a look at the "FormsApplicationDelegate" code, and did override "ContinueUserActivity" and "UserActivityUpdated" where "CheckForAppLink" gets called to find out which UserActivity I have but neither one of those two methods gets called either. I'am sorry but I don't have much experience on iOS, so I don't know how else I can find out or how to set it.

I do activate the AppLink from Safari with a standard HTML link, the OS brings up a pop up asking me if I want to open the Link with my app and when I click ok opens the app.
Comment 3 Rui Marinho 2016-08-08 14:14:52 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. 
If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue, we would very much appreciate it.

Please provide also the html page you are using to trigger with action.

Warm regards,
Xamarin Forms Team
Comment 4 Samantha Houts [MSFT] 2016-12-30 18:56:55 UTC
@Simon Friesenbichler: Are you still experiencing this issue? If so, can you please provide a reproduction of the issue to help us track it down?
Comment 5 Chris Hardy [MSFT] 2017-06-19 16:37:01 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!
Comment 6 faceoffers28 2018-04-24 19:07:48 UTC
I can't get Universal Links to work in my Xamarin.Forms iOS app. My development environment is Visual Studio 2017 Enterprise and Xamarin.iOS 11.9.1.24. I'm using version 11.3 of the SDK. I'm running 11.3 on my iPhone 6S. I'm running 9.3.5 on my iPad Mini 2. I can't get Universal Links to work on either device. The OnAppLinkRequestReceived method is not getting called. I'm using version 2.5.1.444934 of Xamarin.Forms.