Bug 42826 - AppCompat: No resource found that matches the given name
Summary: AppCompat: No resource found that matches the given name
Status: RESOLVED DUPLICATE of bug 41123
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-07-27 05:29 UTC by adrianknight89
Modified: 2016-08-14 13:29 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
sample project (32.47 KB, application/zip)
2016-07-27 05:29 UTC, adrianknight89
Details
screenshots (92.31 KB, application/zip)
2016-07-27 05:31 UTC, adrianknight89
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 41123

Description adrianknight89 2016-07-27 05:29:58 UTC
Created attachment 16792 [details]
sample project

I created a XAML PCL app and am trying to compile the Android project against XF 2.3.1.113-pre3. However, I'm getting AppCompat errors related to variables defined in styles.xml. I'm using VS 2015 with Update 3 on Win 10.

Before I compile the app, I clear anything in C:\Users[username]\AppData\Local\Xamarin as well as bin, obj, and packages folders.

Please compile the sample project attached and let me know how to fix the issues.
Comment 1 adrianknight89 2016-07-27 05:31:58 UTC
Created attachment 16793 [details]
screenshots

Here you can see the Android build config, VS errors, and SDK Manager setup.
Comment 2 adrianknight89 2016-07-27 10:48:57 UTC
The problem is I have a slow internet connection and it takes ages to download the zip file in C:\Users[username]\AppData\Local\Xamarin\zips. Visual Studio hangs in the middle of build making it look like there is some kind of error. Downloaded zip file eventually gets corrupted.

See this thread: https://forums.xamarin.com/discussion/17349/compilation-error-unzipping-failed-please-download-https-dl-since-xamarin-studio-v5-0-upgrade/p1

Xamarin should give some kind of warning to the user that the file is being downloaded or corrupt.
Comment 3 Rui Marinho 2016-08-11 10:54:13 UTC
Moving this to Xamarin.Androdi team.
Comment 4 Jonathan Pryor 2016-08-14 13:29:14 UTC

*** This bug has been marked as a duplicate of bug 41123 ***