Bug 42821 - Generating an IPA creates new folders every time
Summary: Generating an IPA creates new folders every time
Status: RESOLVED DUPLICATE of bug 41963
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: --- major
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2016-07-26 22:35 UTC by James Clancey
Modified: 2016-07-27 11:33 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 41963

Description James Clancey 2016-07-26 22:35:16 UTC
At some point the generate IPA option started creating unique date time folders to store the IPA inside the bin folder.  This creates unnecessary bloat in our bin folders. Also it makes it difficult to automate things in some build servers.

We need a way to disable this extra nesting, and just put the IPA directly inside the output folder.
Comment 1 GouriKumari 2016-07-27 11:33:07 UTC
@Clancey: This should be fixed in our current C7SR1 beta builds. You will have to set IpaPackageDir property to set a path to output directory. 

Please refer the following bugs: 

https://bugzilla.xamarin.com/show_bug.cgi?id=41963 (XS)
https://bugzilla.xamarin.com/show_bug.cgi?id=42387 (VS)

## Supplemental Info:

I am closing this bug as duplicate of bug 41963. Incase this issue is different, please reopen it.

*** This bug has been marked as a duplicate of bug 41963 ***