Bug 42672 - Cannot Scroll ListView After Using TranslateTo()
Summary: Cannot Scroll ListView After Using TranslateTo()
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-19 18:52 UTC by Jimmy [MSFT]
Modified: 2016-09-23 17:29 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
repro solution (206.30 KB, application/zip)
2016-07-19 18:52 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 42672 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Jimmy [MSFT] 2016-07-19 18:52:44 UTC
Created attachment 16723 [details]
repro solution

### Overview
After using TranslateTo() on a ListView it no longer responds to scrolling gestures. It does however still respond to taps as selecting an item still works. This bug also occurs when the ListView is inside a layout and the layout is translated.


### Steps to Reproduce
1. Run the attached WP 8.1 project
2. Scroll the list
3. Press the toolbar item to translate the ListView
4. Scroll the list again


### Expected Results
The ListView will scroll.


### Actual Results
The ListView does not response.


### Version Info
Tested with Forms 2.3.1-pre2
Comment 1 Leo 2016-09-23 17:28:18 UTC
On a ListView with CachingStrategy=RetainElement if I change the TranslationX of an ItemTemplate View to -50, after I scroll to hide the translated item and go back, it shows at 0 (but the translationx is still at -50). Here is an image showing the problem:

http://i.imgur.com/wco5iFZ.gif
Comment 2 Leo 2016-09-23 17:29:07 UTC
(sorry, posted this on the wrong place)