Bug 42634 - Clicking Labels marks file as dirty
Summary: Clicking Labels marks file as dirty
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: 4.1.0 (C7)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-18 16:04 UTC by Adam Patridge [MSFT]
Modified: 2016-09-02 16:13 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Adam Patridge [MSFT] 2016-07-18 16:04:07 UTC
[Actual Xamarin version = v4.1.1.3 (build 34a92cd)]

When clicking between controls, a Storyboard file will often be marked as dirty (needing a save/discard to close) if the next control is a UILabel.

Steps:
1. New single view app
2. Open Main.storyboard
3. Drag out two labels
4. Drag out two image views
5. Save
6. Click between images (file isn't marked dirty)
7. Click on a label (file will be marked dirty)
[additional optional steps]
8. Save
9. Click the other label (file is marked dirty again)
10. Save
11. Click back to an image (file isn't marked dirty)

The very first click on a label after opening a file does not seem to cause this issue, only subsequent selections.

Just to see what was changing, I saved a copy elsewhere, went through the first few steps and saved it again. The file diff tool I was using didn't see any content changes.
Comment 1 Alan McGovern 2016-07-18 16:14:25 UTC
This is quite likely to have been fixed in master/c8 builds. Can you try with a newer build to see if the issue has gone away? We did nail a bunch of causes of this exact issue several weeks ago.
Comment 2 Alan McGovern 2016-09-02 16:13:56 UTC
I'll assume all cases have been fixed. If not please reopen again! Thanks