Bug 42557 - [Android/AppCompat] Back button is not hidden/show when using NavigationPage.SetHasBackButton after navigation
Summary: [Android/AppCompat] Back button is not hidden/show when using NavigationPage....
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.1
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-14 14:15 UTC by Stefan de Vogelaere
Modified: 2016-07-19 01:40 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Stefan de Vogelaere 2016-07-14 14:15:51 UTC
Android AppCompat issue

When you use NavigationPage.SetHasBackButton(this, false) after the page has navigated, the Back button is still showed.
Comment 1 Stefan de Vogelaere 2016-07-14 14:27:46 UTC
In iOS this is working.

PR submitted
https://github.com/xamarin/Xamarin.Forms/pull/256
Comment 2 Samantha Houts [MSFT] 2016-07-19 01:40:19 UTC
Should be fixed in 2.3.2-pre1. Thanks!