Bug 42490 - Unable to install master XVS on some machines.
Summary: Unable to install master XVS on some machines.
Status: VERIFIED DUPLICATE of bug 43037
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: High major
Target Milestone: 4.2.0 (C8)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-12 12:06 UTC by Arpit Jha
Modified: 2016-08-12 19:25 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 43037

Description Arpit Jha 2016-07-12 12:06:53 UTC
Actual Result: While installing XVS builds on some of the windows machines we are encountering error " Contact your vendor for this package. .

Non working machines environment details as follows:
Machine1: https://gist.github.com/Arpit360/e0e4a0f129b80127ad5fa9784c35d784


However on some machiens we are sucesfully able ton install the XVS build. Details of such machiens a follows:
Machine 1 : https://gist.github.com/tajinder360/cd8ea72c9dce0f1016af558095c775aa

By reviewing the XVS logs we tried investing the root cause , 

Expected Result: user should able to install build successfully.
Comment 1 Arpit Jha 2016-07-12 12:16:24 UTC
An update to above issue here is the XVS build that I am using Xamarin.VisualStudio_99.0.0.2789_5cddab2b16f0fc254cc353949dfc8288754f94f1
Comment 2 Jose Gallardo 2016-07-12 12:23:37 UTC
Can you please confirm if failing env have .Net 4.6 and MS Build 2015 Tools installed:


https://www.microsoft.com/en-us/download/details.aspx?id=48137

https://www.microsoft.com/en-us/download/details.aspx?id=48159


We do require those dependencies. 

Also, it would be great if you can share a screencast and the Setup log.

In case it's needed, please take a look at:
https://technet.microsoft.com/en-us/library/cc759262(v=ws.10).aspx
You can use msiexec /L

Thanks
Comment 3 Arpit Jha 2016-07-12 12:26:29 UTC
Screencast for the same http://www.screencast.com/t/INdmMU7vq7 

Additional Info: I am able to install C7 builds
Comment 4 Jose Gallardo 2016-08-12 19:23:58 UTC
It looks like we have the same issue reported as Bug 43037
And it's more frequent now.
Marking this bug as duplicate.

*** This bug has been marked as a duplicate of bug 43037 ***