Bug 42364 - ContextAction does not dismiss on tab page change
Summary: ContextAction does not dismiss on tab page change
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.0
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-07-05 18:50 UTC by Rob Hedgpeth
Modified: 2016-08-03 09:00 UTC (History)
4 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rob Hedgpeth 2016-07-05 18:50:57 UTC
After long pressing a ListView item to show a context action over the navigation bar in Xamarin.Forms (Android) the actionable view does not dismiss when navigating to another page within a tabbed page.

Scenario: Tabbed page with two pages

Steps of reproduction:

1.) Load tabbed page with first page that contains a ListView with a ContextAction defined for the ViewCells.
2.) Long press a list item to see the ContextAction overlay a view on the nav bar.
3.) Navigate to the second page in the tabbed page, and notice that the overlaid ContextAction view does not dismiss.
Comment 1 Rui Marinho 2016-08-03 09:00:36 UTC
Should be fixed in 2.3.2-pre1. Thank you!