Bug 4215 - Incorrect Abstraction References
Summary: Incorrect Abstraction References
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2012-04-03 23:25 UTC by Karl Schulze
Modified: 2012-04-05 07:27 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Karl Schulze 2012-04-03 23:25:07 UTC
Working with an open source project, TimeSeriesDb (http://code.google.com/p/timeseriesdb/source/list r145). The library compiles / works well in windows/.Net 4.0, and I am trying to port it to a mac / mono 2.8.

Several compile time errors occur when building from source in mono, first you have to update the projects to use .net 4.0 instead of the client profile. After this update, I run into the following issues...

Dispose member of an object not correctly mapping.
Protected members of a different superclass unavailable to another superclass with the same base class.

I believe these are bugs in the mono compiler, as the library compiles fine in VS10 / .Net 4.0.

Let me know what you find.

-Karl
Comment 1 Marek Safar 2012-04-05 07:27:32 UTC
Fixed in master.

Note, the issue with client profile is xbuild issue