Bug 42145 - Error adding Google play services Cloud messaging (29.0.0.1) in the project
Summary: Error adding Google play services Cloud messaging (29.0.0.1) in the project
Status: RESOLVED DUPLICATE of bug 37970
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: Staging (addons.xamstage.com)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
URL:
Depends on:
Blocks:
 
Reported: 2016-06-24 06:49 UTC by Anurag
Modified: 2016-06-24 10:15 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 37970

Description Anurag 2016-06-24 06:49:18 UTC
Steps to reproduce
1. Fresh install Xamarin studio on mac
2. Create Xamarin.forms project
3. .Droid project add Google play services- Cloud messaging (gcm) 29.0.0.1 component

Attaching error below

  GET https://api.nuget.org/v3/registration1-gz/xamarin.googleplayservices.gcm/index.json
  OK https://api.nuget.org/v3/registration1-gz/xamarin.googleplayservices.gcm/index.json 947ms
Attempting to gather dependency information for package 'Xamarin.GooglePlayServices.Gcm.29.0.0.2' with respect to project 'XamHawk.Droid', targeting 'MonoAndroid,Version=v6.0'
Attempting to resolve dependencies for package 'Xamarin.GooglePlayServices.Gcm.29.0.0.2' with DependencyBehavior 'Lowest'
Resolving actions to install package 'Xamarin.GooglePlayServices.Gcm.29.0.0.2'
Resolved actions to install package 'Xamarin.GooglePlayServices.Gcm.29.0.0.2'
For adding package 'Xamarin.Android.Support.v4.23.1.1.1' to project 'XamHawk.Droid' that targets 'monoandroid60'.
For adding package 'Xamarin.Android.Support.v4.23.1.1.1' to project 'XamHawk.Droid' that targets 'monoandroid60'.
Adding package 'Xamarin.Android.Support.v4.23.1.1.1' to folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Added package 'Xamarin.Android.Support.v4.23.1.1.1' to folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Added reference 'Xamarin.Android.Support.v4' to project 'XamHawk.Droid'.
Added package 'Xamarin.Android.Support.v4.23.1.1.1' to 'packages.config'
Added file 'packages.config' to project 'XamHawk.Droid'.
Successfully installed 'Xamarin.Android.Support.v4 23.1.1.1' to XamHawk.Droid
For adding package 'Xamarin.GooglePlayServices.Basement.29.0.0.2' to project 'XamHawk.Droid' that targets 'monoandroid60'.
For adding package 'Xamarin.GooglePlayServices.Basement.29.0.0.2' to project 'XamHawk.Droid' that targets 'monoandroid60'.
Adding package 'Xamarin.GooglePlayServices.Basement.29.0.0.2' to folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Added package 'Xamarin.GooglePlayServices.Basement.29.0.0.2' to folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Added reference 'Xamarin.GooglePlayServices.Basement' to project 'XamHawk.Droid'.
Added package 'Xamarin.GooglePlayServices.Basement.29.0.0.2' to 'packages.config'
Added file 'packages.config' to project 'XamHawk.Droid'.
Successfully installed 'Xamarin.GooglePlayServices.Basement 29.0.0.2' to XamHawk.Droid
  GET https://api.nuget.org/packages/xamarin.googleplayservices.base.29.0.0.2.nupkg
  OK https://api.nuget.org/packages/xamarin.googleplayservices.base.29.0.0.2.nupkg 26ms
Acquiring lock for the installation of Xamarin.GooglePlayServices.Base 29.0.0.2
Acquired lock for the installation of Xamarin.GooglePlayServices.Base 29.0.0.2
Installing Xamarin.GooglePlayServices.Base 29.0.0.2.
Error downloading 'Xamarin.GooglePlayServices.Base.29.0.0.2 : Xamarin.Android.Support.v4 [23.1.1.1, ), Xamarin.GooglePlayServices.Basement [29.0.0.2, 29.0.0.2]' from 'https://api.nuget.org/packages/xamarin.googleplayservices.base.29.0.0.2.nupkg'.
The UTC time represented when the offset is applied must be between year 0 and 10,000.
Parameter name: offset
Install failed. Rolling back...
Package 'Xamarin.GooglePlayServices.Base.29.0.0.2 : Xamarin.Android.Support.v4 [23.1.1.1, ), Xamarin.GooglePlayServices.Basement [29.0.0.2, 29.0.0.2]' does not exist in project 'XamHawk.Droid'
Removed package 'Xamarin.GooglePlayServices.Basement.29.0.0.2 : Xamarin.Android.Support.v4 [23.1.1.1, )' from 'packages.config'
Added file 'packages.config' to project 'XamHawk.Droid'.
Removed reference 'Xamarin.GooglePlayServices.Basement' from project 'XamHawk.Droid'.
Removed package 'Xamarin.Android.Support.v4.23.1.1.1' from 'packages.config'
Removed file 'packages.config'.
Removed reference 'Xamarin.Android.Support.v4' from project 'XamHawk.Droid'.
Package 'Xamarin.GooglePlayServices.Base.29.0.0.2 : Xamarin.Android.Support.v4 [23.1.1.1, ), Xamarin.GooglePlayServices.Basement [29.0.0.2, 29.0.0.2]' does not exist in folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Removing package 'Xamarin.GooglePlayServices.Basement.29.0.0.2 : Xamarin.Android.Support.v4 [23.1.1.1, )' from folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Removed folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.GooglePlayServices.Basement.29.0.0.2/lib/MonoAndroid41'.
Removed folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.GooglePlayServices.Basement.29.0.0.2/build'.
Removed folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.GooglePlayServices.Basement.29.0.0.2/lib'.
Removed file 'Xamarin.GooglePlayServices.Basement.29.0.0.2.nupkg' from folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.GooglePlayServices.Basement.29.0.0.2'.
Removed folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.GooglePlayServices.Basement.29.0.0.2'.
Removed package 'Xamarin.GooglePlayServices.Basement.29.0.0.2 : Xamarin.Android.Support.v4 [23.1.1.1, )' from folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Removing package 'Xamarin.Android.Support.v4.23.1.1.1' from folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Removed folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.Android.Support.v4.23.1.1.1/lib/MonoAndroid403'.
Removed folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.Android.Support.v4.23.1.1.1/lib'.
Removed file 'Xamarin.Android.Support.v4.23.1.1.1.nupkg' from folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.Android.Support.v4.23.1.1.1'.
Removed folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages/Xamarin.Android.Support.v4.23.1.1.1'.
Removed package 'Xamarin.Android.Support.v4.23.1.1.1' from folder '/Users/anuragkondeya/XamarinWorkSpace/XamHawkDemoApp/XamHawkDemoApp/XamHawk/packages'
Error downloading 'Xamarin.GooglePlayServices.Base.29.0.0.2 : Xamarin.Android.Support.v4 [23.1.1.1, ), Xamarin.GooglePlayServices.Basement [29.0.0.2, 29.0.0.2]' from 'https://api.nuget.org/packages/xamarin.googleplayservices.base.29.0.0.2.nupkg'.

******************************************************************************************************************



Xamarin Studio Community
Version 6.1 (build 4963)
Installation UUID: 52ff1bb5-d171-4ed6-8185-ddfaa07ee4d6
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/fcf7a6d) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000148

NuGet
Version: 3.4.3.0

Xamarin.Profiler
Not Installed

Apple Developer Tools
Xcode 7.3.1 (10188.1)
Build 7D1014

Xamarin.Mac
Version: 2.9.0.719 (Xamarin Studio Community)

Xamarin.Android
Version: 6.1.99.224 (Xamarin Studio Community)
Android SDK: /Users/anuragkondeya/Library/Android/sdk
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 25.1.7
SDK Platform Tools Version: 24.0.0
SDK Build Tools Version: 24

Java SDK: /usr
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin Android Player
Not Installed

Xamarin.iOS
Version: 9.9.0.288 (Xamarin Studio Community)
Hash: ef65ca5
Branch: master
Build date: 2016-06-07 21:27:36-0400

Build Information
Release ID: 601004963
Git revision: b37c52e0249c009e308eb144957ac97d1003ec0e
Build date: 2016-06-10 12:00:02-04
Xamarin addins: db4bae9b11a32d16ee009695cd1bfa36455187b0
Build lane: monodevelop-lion-cycle8-preview2

Operating System
Mac OS X 10.11.5
Darwin anurags-MacBook-Pro.local 15.5.0 Darwin Kernel Version 15.5.0
    Tue Apr 19 18:36:36 PDT 2016
    root:xnu-3248.50.21~8/RELEASE_X86_64 x86_64
Comment 1 Matt Ward 2016-06-24 10:15:22 UTC
The 'UTC time represented when the offset is applied must be between year 0 and 10,000' is a problem with using NuGet v3 with Mono if your timezone has a positive offset.

Workarounds are:

1) Switch to Xamarin Studio 6.0 which uses NuGet v2 which is not affected by this problem.
2) Change your local time zone so it is not using a positive offset (e.g. UTC+0).

*** This bug has been marked as a duplicate of bug 37970 ***