Bug 42023 - Xamarin Install leads to Problems with Visual Studio Tools for Unity
Summary: Xamarin Install leads to Problems with Visual Studio Tools for Unity
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 4.1.0 (C7)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Joaquin Jares
URL:
Depends on:
Blocks:
 
Reported: 2016-06-21 08:23 UTC by Florian
Modified: 2016-07-07 18:50 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: It was working before 9.8

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Florian 2016-06-21 08:23:44 UTC
Xamarin and Visual Studio Tools for Unity are not working together when it comes to debugging. I can't attach the debugger to Unity anymore. Xamarin works fine but somehow after installing Xamarin it breaks the Visual Studio Tools for Unity.

Here is a more detailed description of the bug, the solution works for me as well (which is deinstalling Xamarin):
http://stackoverflow.com/questions/37798816/visual-studio-debugger-not-attaching-to-unity/37826299
Comment 2 Joaquin Jares 2016-06-21 12:45:03 UTC
This issue has been identified and we're working on a fix.
Comment 3 Joaquin Jares 2016-07-07 18:50:57 UTC
Fixed in Unity and in Xamarin. In Xamarin the fix is not released yet. Marking as fixed for internal QA.