Bug 420 - Filenames with ampersands are displayed incorrectly in solution pad
Summary: Filenames with ampersands are displayed incorrectly in solution pad
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.6 RC 1
Hardware: Macintosh Mac OS
: --- minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-25 10:41 UTC by Adrian
Modified: 2011-12-23 17:12 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Adrian 2011-08-25 10:41:09 UTC
I have a project with a couple of directories and files that contain an ampersand (&) in their name. 

In the solution pad, the files are not displayed at all and the directories are displayed using a seemingly random names that change on mouse hover. It seems like it picks the name of the entry right above or the two entries right below in the list.

In the file pad I'm able to browse those files and folders without issues.
Comment 1 Jeffrey Stedfast 2011-12-23 17:12:24 UTC
Fixed in git master.