Bug 41818 - Find Reference in XS seems to cause GC problems
Summary: Find Reference in XS seems to cause GC problems
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-06-14 20:52 UTC by Stephen Shaw
Modified: 2016-09-14 01:45 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Stephen Shaw 2016-06-14 20:52:24 UTC
The customer right clicked on a class and then did find all references. The first time it worked, but the second time it stopped working until restarting XS.
This is the stacktrace from the XS logs:
https://gist.github.com/dlprows/40e9dcc925a9d21fd2498aafc284b24f - full trace

Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) object.__icall_wrapper_mono_object_isinst (object,intptr) <IL 0x00008, 0x0005f>
  at (wrapper stelemref) object.virt_stelemref_class (intptr,object) <IL 0x00023, 0x00062>
  at System.Collections.Immutable.ImmutableArray`1/Builder<T_REF>.ToArray () <IL 0x00020, 0x0008b>
  at System.Collections.Immutable.ImmutableArray`1/Builder<T_REF>.ToImmutable () <IL 0x0000f, 0x0007f>
  at Microsoft.CodeAnalysis.ArrayBuilder`1<T_REF>.ToImmutable () <IL 0x00006, 0x00022>
  at Microsoft.CodeAnalysis.ArrayBuilder`1<T_REF>.ToImmutableAndFree () <IL 0x00001, 0x00015>
Comment 1 Rodrigo Kumpera 2016-09-14 01:45:35 UTC
Can't do anything with this bug.

Can't repro based on description nor has the stacktrace native symbols.