Bug 4171 - Crashes when trying to run Xwt's MacTest in MacOS SnowLeopard 10.6.2 (Mono 2.11)
Summary: Crashes when trying to run Xwt's MacTest in MacOS SnowLeopard 10.6.2 (Mono 2.11)
Status: RESOLVED INVALID
Alias: None
Product: MonoMac
Classification: Desktop
Component: Bindings ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-31 07:32 UTC by Andres G. Aragoneses
Modified: 2012-04-02 15:45 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
crash dump (35.66 KB, text/plain)
2012-03-31 07:32 UTC, Andres G. Aragoneses
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Andres G. Aragoneses 2012-03-31 07:32:38 UTC
Created attachment 1607 [details]
crash dump

I just installed Mono MDK and MRE 2.11 (along with MonoDevelop 2.8), opened XWT solution and tried to run the sample "MacTest", and I got a crash.
Comment 1 Andres G. Aragoneses 2012-03-31 07:36:00 UTC
oh, looks like NSInvalidArgumentException so this may be a bug in MonoMac?
Comment 2 Andres G. Aragoneses 2012-03-31 08:32:27 UTC
Removed the Label from the samples and I get a similar error, which seems to indicate something wrong with the "fittingSize":

2012-03-31 13:25:53.437 MacTest[611:613] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[Xwt.Mac.CustomSplitView fittingSize]: unrecognized selector sent to instance 0xc45e200'

Although at this point not sure if this is a Xwt bug instead of MonoMac.
Comment 3 Mikayla Hutchinson [MSFT] 2012-04-02 15:45:17 UTC
XWT appears to be using the constraint-based layout system that was introduced in MacOS 10.7, i.e. this isn't a MonoMac bug.

It's either an Xwt bug or an Xwt limitation :)