Bug 41544 - win32 mono is missing the glib-networking module for TLS/SSL support.
Summary: win32 mono is missing the glib-networking module for TLS/SSL support.
Status: CONFIRMED
Alias: None
Product: Installers
Classification: Mono
Component: Windows Installer ()
Version: 4.2.0 (C6)
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jo Shields
URL:
Depends on:
Blocks:
 
Reported: 2016-06-07 03:41 UTC by Hin-Tak Leung
Modified: 2017-05-16 21:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Browser test screen shot,showing that message. (8.78 KB, image/png)
2016-06-07 03:41 UTC, Hin-Tak Leung
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 41544 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Hin-Tak Leung 2016-06-07 03:41:08 UTC
Created attachment 16212 [details]
Browser test screen shot,showing that message.

I have a webkit-sharp example which works well under native Linux mono for both http and https web sites. Running it under win32 mono, however, works for http web site, but shows a rather interesting message about "TLS/SSL support not available. Please install glib-networking" .

Under linux I have these for the glib-networking package:
/usr/lib64/gio/modules/libgiognomeproxy.so
/usr/lib64/gio/modules/libgiognutls.so
/usr/lib64/gio/modules/libgiolibproxy.so

and my ming32-glib-networking package have this dll:
lib/gio/modules/libgiognutls.dll

so I am fairly sure that's what you need and haven't got with the glib-sharp bundled.