Bug 41537 - Implement System.Numerics.Vector* etc APIs
Summary: Implement System.Numerics.Vector* etc APIs
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: General ()
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2016-06-06 21:18 UTC by Alexander Köplinger [MSFT]
Modified: 2016-07-04 10:48 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alexander Köplinger [MSFT] 2016-06-06 21:18:43 UTC
They're missing from https://github.com/mono/mono/tree/master/mcs/class/System.Numerics. We can use the ref src implementation from https://github.com/mono/mono/tree/master/mcs/class/referencesource/System.Numerics/System/Numerics

Make sure to add type forwarders to https://github.com/mono/mono/tree/master/mcs/class/System.Numerics.Vectors when this is done.
Comment 1 Rodrigo Kumpera 2016-06-08 14:56:16 UTC
The RS implementation is not the same as : https://github.com/dotnet/corefx/tree/master/src/System.Numerics.Vectors/src/System/Numerics
Comment 3 Alexander Köplinger [MSFT] 2016-06-08 16:35:44 UTC
For reference since I didn't remember on our call earlier today, I noticed this due to: https://github.com/travis-ci/travis-ci/issues/6137
Comment 4 Marek Safar 2016-07-04 10:48:57 UTC
Fixed in master and Mono 4.5.1