Bug 41534 - Unable to build project from command line when specifying an older tools version
Summary: Unable to build project from command line when specifying an older tools version
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: 4.4.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-06-06 20:26 UTC by Peter Collins
Modified: 2018-03-15 10:40 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
simple console app (3.63 KB, application/zip)
2016-06-06 20:27 UTC, Peter Collins
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Peter Collins 2016-06-06 20:26:30 UTC
This came about as part of adding coverage for #41227. I see the following failure when overriding the project's tools version to something older and building via xbuild from mono 4.4.

> Error initializing task Message: Not registered task Message.
Diagnostic build output:
https://gist.github.com/pjcollins/4de96a38b0425ca119dc424102bb77dd

Steps to reproduce:
1. Download the attached project, and attempt to build with one of the following tools versions:
> xbuild /tv:2.0 ConsoleAppTest.sln
> xbuild /tv:3.0 ConsoleAppTest.sln
> xbuild /tv:3.5 ConsoleAppTest.sln

Environment:
Mono JIT compiler version 4.4.0 (mono-4.4.0-branch-c7-baseline/5995f74 Thu Jun  2 15:13:10 EDT 2016)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           normal
	SIGSEGV:       altstack
	Notification:  kqueue
	Architecture:  x86
	Disabled:      none
	Misc:          softdebug 
	LLVM:          yes(3.6.0svn-mono-master/a173357)
	GC:            sgen
Comment 1 Peter Collins 2016-06-06 20:27:02 UTC
Created attachment 16206 [details]
simple console app
Comment 2 Marek Safar 2018-03-15 10:40:04 UTC
We deprecated xbuild and recommend using msbuild instead. Switching to msbuild will also most likely resolve the issue you reported.