Bug 41387 - The installed Android SDK is too old. Version 24.3.4 or newer is required. Please update to the latest version.
Summary: The installed Android SDK is too old. Version 24.3.4 or newer is required. Pl...
Status: RESOLVED FIXED
Alias: None
Product: Mobile API (Preview)
Classification: Xamarin
Component: Xamarin.Android ()
Version: Preview 0.6.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
URL:
Depends on:
Blocks:
 
Reported: 2016-05-31 08:01 UTC by Maheswari S
Modified: 2017-05-24 17:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
To expose the error messages (80.13 KB, image/png)
2016-05-31 08:01 UTC, Maheswari S
Details
To expose the error messages (56.76 KB, image/png)
2016-05-31 08:13 UTC, Maheswari S
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Maheswari S 2016-05-31 08:01:52 UTC
Created attachment 16139 [details]
To expose the error messages

I have installed Xamarin upon visual studio 2015. I newly created one Blank App(Native Portable) project. Then I opened App1.Droid->Resources->Layout->Main.axml it throws error like "The installed Android SDK is too old. Version 24.3.4 or newer is required. Please update to the latest version.". I am not able to proceed further. I have installed packages from online. I don;t have local copy for the Xamarin setup while installing. Can you please provide me the steps to resolve it and make the application work?
Comment 1 Maheswari S 2016-05-31 08:13:53 UTC
Created attachment 16140 [details]
To expose the error messages

I opened the Android SDK Manager. I tried to install the packages, the system throws error, not able to install.
Comment 2 Ed 2016-08-16 13:16:46 UTC
Same thing with MAC version. 

Version details:

Xamarin Studio Community
Version 6.0.2 (build 73)
Installation UUID: 7c6ce93e-cd67-4bed-822c-c501a6ca969c
Runtime:
	Mono 4.4.2 (mono-4.4.0-branch-c7sr1/f72fe45) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404020011

Xamarin.Profiler
Not Installed

Apple Developer Tools
Xcode 7.3.1 (10188.1)
Build 7D1014

Xamarin.iOS
Version: 9.8.2.22 (Xamarin Studio Community)
Hash: f37444a
Branch: cycle7-sr1
Build date: 2016-07-28 12:17:02-0400

Xamarin.Mac
Version: 2.8.2.22 (Xamarin Studio Community)

Xamarin.Android
Version: 6.1.2.21 (Xamarin Studio Community)
Android SDK: /Users/user1/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		None installed

SDK Tools Version: 25.1.7
SDK Platform Tools Version: 24.0.1
SDK Build Tools Version: 

Java SDK: /usr
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin Android Player
Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

Build Information
Release ID: 600020073
Git revision: a6f7a24a9723a2d4f5d33c176615b0d44703ab5b
Build date: 2016-07-26 13:36:15-04
Xamarin addins: f5acb37866a0141bc5ddbe95118f18dae4014568
Build lane: monodevelop-lion-cycle7-sr1

Operating System
Mac OS X 10.11.5
Comment 3 Matthew Leibowitz 2017-05-24 17:24:48 UTC
This was fixed in later updates.

Just a note: this issue is not related to components or the Mobile API, but rather the Android designer.