Bug 41382 - cant find pcl namespace even though the pcl is referenced in the .ios Project.
Summary: cant find pcl namespace even though the pcl is referenced in the .ios Project.
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-30 19:22 UTC by Stanley Broo
Modified: 2016-12-22 19:41 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Stanley Broo 2016-05-30 19:22:47 UTC
cant find pcl namespace even though the pcl is referenced in the .ios Project.
A rebuil or a Clean and build wont do it.

WORKAROUND 
Remove reference to the PCL in .ios Project and add it back again.
Comment 1 Jose Gallardo 2016-09-19 17:14:23 UTC
Hi Stanley,

Can you please confirm if this issue is present every time you reopen that project, and you need to remove and add the reference back? Or how do you get in that state?

Also, it would be great if you add the following information:

1. Xamarin Logs
Go to the menu "Help - Xamarin - Zip Logs". Please attach that zip file to the bug report.

2. Environment information
Go to the menu "Help - About Microsoft Visual Studio" and press "Copy Info". Please paste that info in a Bugzilla comment.

Thanks!
Comment 2 Adrian Alonso 2016-12-22 19:41:09 UTC
Please let us know if you still need with this issue. Thanks, Adrian