Bug 41365 - Editing the #r section is incredibly slow
Summary: Editing the #r section is incredibly slow
Status: RESOLVED FIXED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Windows ()
Version: 0.8.1
Hardware: PC Windows
: --- normal
Target Milestone: Future
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-05-28 19:57 UTC by Daniel Cazzulino
Modified: 2016-12-01 05:19 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
#r hanging the UI for a while (4.14 MB, application/x-7z-compressed)
2016-05-28 19:58 UTC, Daniel Cazzulino
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Daniel Cazzulino 2016-05-28 19:57:23 UTC
Something weird is going on while I edit the top section of the doc, specifically when adding #r references. 
It's pretty much impossible to type, with Windows showing the UI as hung altogether for a bit before coming back to life, after every keystroke or mouse clicking in that area.

Attached a video just in case :). I have to copy/paste my #r from elsewhere to be able to move on :(
Comment 1 Daniel Cazzulino 2016-05-28 19:58:33 UTC
Created attachment 16127 [details]
#r hanging the UI for a while
Comment 3 Sandy Armstrong [MSFT] 2016-12-01 05:19:20 UTC
This is fixed in 1.1 (or whatever the next release is called).