Bug 41089 - Frame fails to display when using AppCompat
Summary: Frame fails to display when using AppCompat
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.2.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-15 05:14 UTC by Cody Beyer (MSFT)
Modified: 2018-02-16 23:38 UTC (History)
5 users (show)

Tags: Android ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (54.82 KB, application/zip)
2016-05-15 05:14 UTC, Cody Beyer (MSFT)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 41089 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Cody Beyer (MSFT) 2016-05-15 05:14:36 UTC
Created attachment 16003 [details]
Sample

# Description 

The following app demonstrates an issue where setting a frame fails to display when using AppCompat

# Sample

Attached

# Steps to Reproduce

1. Download sample
2. Open in Xamarin Studio
3. Deploy to Android Emulator

# Expected Results

Frame should be displayed centered

This result can be achieved by removing AppCompat setting, by setting #if to false

# Actual Results

No frame is displayed. 

# Versions

=== Xamarin Studio Business ===

Version 6.0 (build 5104)
Installation UUID: f8d313f4-63a0-4e02-bdac-5fa5c9f331a8
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/81f38a9) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000142

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.3.1 (10188.1)
Build 7D1014

=== Xamarin.iOS ===

Version: 9.8.0.294 (Xamarin Business)
Hash: 6950f7b
Branch: cycle7
Build date: 2016-04-24 15:35:14-0400

=== Xamarin.Android ===

Version: 6.1.0.48 (Xamarin Business)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.8.0.294 (Xamarin Business)

=== Xamarin Inspector ===

Version: 0.8.1.0
Hash: 95792d1
Branch: master
Build date: Thu May 12 22:20:04 UTC 2016

=== Build Information ===

Release ID: 600005104
Git revision: 1345d355d4f1b9677d91e1290a6034e2047bdf36
Build date: 2016-04-26 12:21:45-04
Xamarin addins: 7d85147c75b6dbb4b351906636ef76fdf60307c2
Build lane: monodevelop-lion-cycle7

=== Operating System ===

Mac OS X 10.11.4
Darwin Codys-MacBook-Pro.local 15.4.0 Darwin Kernel Version 15.4.0
	Fri Feb 26 22:08:05 PST 2016
	root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Xamarin Inspector 0.8.1.0
Comment 1 E.Z. Hart [MSFT] 2016-06-03 19:53:09 UTC
Confirmed up through 2.3.0.46-pre3.

It looks like the problem is with the outline of the frame not displaying. In the repro project, if the BackgroundColor property of the Frame is set to a color other than white, the frame displays. If the HasShadow property is set to true, the shadow displays. It's just the outline which doesn't show up, no matter what color it's set to.
Comment 2 Alberto 2017-07-21 08:09:23 UTC
Can you plean update on this? Frame is a basic control of Xamarin Forms and after 1 year there is no fix yet