Bug 4107 - On Mono 2.11 the IDE fails to open source files.
Summary: On Mono 2.11 the IDE fails to open source files.
Status: RESOLVED DUPLICATE of bug 4123
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.8.8.1
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-27 07:01 UTC by Dylan Borg
Modified: 2012-03-28 19:46 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 4123

Description Dylan Borg 2012-03-27 07:01:50 UTC
After an upgrade to Mono 2.11 on Ubuntu 12.04 (packaged Mono 2.11 and Monodevelop 2.8.8.1 myself) , The IDE fails to open source files complaining that they are too big to open. In reality these files are very smal in size. This happens in generic projects and even C# projects. I did not try with VB project types.
Comment 1 Mikayla Hutchinson [MSFT] 2012-03-27 18:35:46 UTC
Do you have a stacktrace?
Comment 2 Mikayla Hutchinson [MSFT] 2012-03-28 15:04:51 UTC
.

*** This bug has been marked as a duplicate of bug 4123 ***
Comment 3 Dylan Borg 2012-03-28 16:36:29 UTC
dylan@ubuntu-server:~$ monodevelop
ERROR [2012-03-28 22:35:17Z]: Error while reading welcome page contents.
System.ArgumentNullException: Argument cannot be null.
Parameter name: stream
  at System.IO.StreamReader.Initialize (System.IO.Stream stream, System.Text.Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize) [0x00000] in <filename unknown>:0 
  at System.IO.StreamReader..ctor (System.IO.Stream stream, System.Text.Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize, Boolean leaveOpen) [0x00000] in <filename unknown>:0 
  at System.IO.StreamReader..ctor (System.IO.Stream stream, System.Text.Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize) [0x00000] in <filename unknown>:0 
  at System.IO.StreamReader..ctor (System.IO.Stream stream) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.IO.StreamReader:.ctor (System.IO.Stream)
  at System.Xml.Linq.XDocument.Load (System.IO.Stream stream) [0x00000] in <filename unknown>:0 
  at MonoDevelop.Ide.WelcomePage.WelcomePageBranding..cctor () [0x00000] in <filename unknown>:0 

This appears on startup...
Comment 4 Mikayla Hutchinson [MSFT] 2012-03-28 19:46:54 UTC
Thanks, but that doesn't look like the FileInfo.Length issue, I think it's a harmless warning that was fixed in https://github.com/mono/monodevelop/commit/f8706cb0f180ef2853341f17e85f0d41f91195b9. However, I marked this as duplicate of a bug that has a small test case for the underlying classlibs/runtime issue, so we have the info needed.