Bug 41041 - [XVS 4.1] Incorrect string "iOS Community" mentioned in log files when using VS Professional license level
Summary: [XVS 4.1] Incorrect string "iOS Community" mentioned in log files when using ...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.1.0 (C7)
Hardware: PC Windows
: High normal
Target Milestone: 4.1.0 (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-11 21:42 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-05-19 05:17 UTC (History)
5 users (show)

Tags: BZRC7B1_C6SR3S1
Is this bug a regression?: ---
Last known good build:


Attachments
Log files and detailed version info (3.54 KB, application/zip)
2016-05-11 21:42 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-05-11 21:42:48 UTC
Created attachment 15978 [details]
Log files and detailed version info

[XVS 4.1] Incorrect level "iOS Community" mentioned in log files when using VS Professional license level



I'd estimate this inaccurate text is a moderate concern in terms of proper messaging because it could lead customers to think either (a) that they are not being granted the "full" VS Professional permissions or (b) that they are unintentionally violating the Community Edition terms of use.




## Regression status: regression in Cycle 7

BAD:  XamarinVS 4.1.0.462 (fb9e9f3)
GOOD: XamarinVS 4.0.3.214 (0dd817c)




## Steps to replicate

1. Ensure you are logged out of any Xamarin account under "Tools > Xamarin Account" in Visual Studio.

2. Open Visual Studio Professional.

3. Navigate to "Tools > Options > Xamarin > Android" (to cause the Xamarin extensions to be loaded).




## BAD Results (with 4.1.0.462 (fb9e9f3))

The `*Ide.log` file (from "Help > Xamarin > Zip Logs")  _incorrectly_ mentions "iOS Community":

> Xamarin.VisualStudio.ActivationManager Information: 0 : [2016-05-11 17:06:04.0462] Read license: iOS Community




## GOOD Results (with 4.0.3.214 (0dd817c))

As desired, the string "Community" never appears in the log files (because I'm using VS Professional).




## Additional version info (brief)

Visual Studio Professional 2015 Update 1
Windows 8.1 (64-bit)