Bug 4096 - Auto indent ignores code format settings
Summary: Auto indent ignores code format settings
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: Trunk
Hardware: PC Linux
: Low normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
: 4838 ()
Depends on:
Blocks:
 
Reported: 2012-03-26 10:24 UTC by Denis Washington
Modified: 2013-09-04 06:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Denis Washington 2012-03-26 10:24:37 UTC
I disabled indentation of namespace content in both the MonoDevelop and project-specific settings. However, pressing Enter after the opening brace of a namespace declaration still inserts an indent. What's worse, if I fix this manually and later press Enter after a statement in a method, the next line is indented as if the namespace content were indented, that is, it is indented one level more than the previous statement.

The "Format Code" action in the menu correctly respects the namespace indentation setting.
Comment 1 Mike Krüger 2012-05-03 00:28:11 UTC
*** Bug 4838 has been marked as a duplicate of this bug. ***
Comment 2 Rune Skovbo Johansen 2013-07-03 07:03:39 UTC
In recent versions of MonoDevelop (tested with 4.0.1) this bug is even more severe since it also affects indentation on paste operations, no matter if Smart Indentation is even turned on or not. See case 13031 for details.
Comment 3 Mikayla Hutchinson [MSFT] 2013-07-03 12:55:28 UTC
4.0.1 is 5 months old, have you tried 4.0.9?
Comment 4 Rune Skovbo Johansen 2013-07-03 17:11:43 UTC
I downloaded Xamarin Studio 4.0.9 to see, and I can confirm that both this bug and the paste bug (case 13031) are still there.
Comment 5 Mike Krüger 2013-09-04 06:32:31 UTC
fixed with the new engine.