Bug 40956 - Unable to install Video Player Component
Summary: Unable to install Video Player Component
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Component Store ()
Version: Production (addons.xamarin.com)
Hardware: PC All
: --- normal
Target Milestone: ---
Assignee: Tim Miller
URL:
Depends on:
Blocks:
 
Reported: 2016-05-08 10:16 UTC by Matt Ward
Modified: 2016-06-02 20:58 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Matt Ward 2016-05-08 10:16:37 UTC
This was reported on the forum:

http://forums.xamarin.com/discussion/comment/195669

When you download the Xamarin.Forms Video Player component (trial) either directly or using Xamarin Studio the downloaded component's .xam file is zero bytes. If you try to install the trial version of the component with Xamarin Studio you see the error message "Error downloading component: Cannot find central directory" due to the component's .xam file being zero bytes long.

https://components.xamarin.com/view/video-player
Comment 1 Tim Miller 2016-05-10 13:50:22 UTC
The file needs to be reuploaded.  There was a bug where if you tried to upload a trial version it would try to read from the normal version instead. But since that one was already read into memory, it would read in nothing, and produce a zero byte file.

This has been fixed, so once the file is reuploaded to the store, it will work again.
Comment 2 Tim Miller 2016-06-02 20:58:59 UTC
The file was reuploaded and the trial can now be downloaded again. So I'm calling this fixed.