Bug 40904 - Xamarin Android crashes with SIGABRT when debugging
Summary: Xamarin Android crashes with SIGABRT when debugging
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 6.0.1 (C6SR1)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-05 14:06 UTC by Prashant Cholachagudda
Modified: 2017-06-29 15:20 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
ADB Log (7.02 KB, text/plain)
2016-05-05 14:06 UTC, Prashant Cholachagudda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 40904 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Prashant Cholachagudda 2016-05-05 14:06:10 UTC
Customer is getting a SIGABRT when trying to debug on Android (using Xamarin.Android). This seems to depend on whether certain breakpoints are enabled or not.

If they disable the breakpoint in question the app runs fine. But as soon as the breakpoint gets enabled the app crashes with a SIGABRT.

Customer is using the latest stable builds.
Comment 1 Prashant Cholachagudda 2016-05-05 14:06:36 UTC
Created attachment 15914 [details]
ADB Log
Comment 4 Andi McClure 2016-06-03 21:39:39 UTC
I am looking at this, I need to know what "the breakpoint in question" is so I can reproduce it. What did they breakpoint and what are the reproduction steps to hit the breakpoint?