Bug 40863 - Android app builds once (and only once)
Summary: Android app builds once (and only once)
Status: RESOLVED DUPLICATE of bug 40156
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 6.0.99
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-05-04 15:41 UTC by nbe
Modified: 2016-05-04 20:40 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Diagnostics build output file (276.08 KB, text/plain)
2016-05-04 15:41 UTC, nbe
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 40156

Description nbe 2016-05-04 15:41:06 UTC
Created attachment 15904 [details]
Diagnostics build output file

I have installed the necessary tools to debug Apps on Android-N and the latest version of N preview SDK and tools.

I was able to build the app once, modifying a tiny bit of code (or just a rebuild) fails. In order to build again I have to revert Visual studio to the stable channel, uninstall Android N preview and SDK. The apps than build fine multiple times. After installing N required tools again, the app builds once (and only once).

The app is nothing special, just the default android app created by Visual studio template (no extra recources/code files have been added).

As attachement the Diagnostics build output file.
Comment 1 Peter Collins 2016-05-04 20:40:10 UTC
Judging by the error in the build output:
>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1824,3): error MSB6006: "aapt.exe" exited with code -1073741819.

This looks to me to be a duplicate of Bug #40156

*** This bug has been marked as a duplicate of bug 40156 ***