Bug 40840 - Error message XA0000 during Android debug deployment to device
Summary: Error message XA0000 during Android debug deployment to device
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-05-03 20:59 UTC by Mike Almond
Modified: 2017-08-23 20:51 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log file (996 bytes, text/plain)
2016-05-03 21:27 UTC, Mike Almond
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Mike Almond 2016-05-03 20:59:38 UTC
C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: An element with the same key already exists in the dictionary. (XA0000) (Tms.Technician.UI.Droid) monodroid 

This message occurs on both Xamarin Studio 5.10.3 and Visual Studio 2015 Update 2 with Xamarin 4.0.3.214 and Xamarin.Android 6.0.3.5.
Comment 1 Mike Almond 2016-05-03 21:27:41 UTC
Created attachment 15897 [details]
Log file
Comment 2 Jonathan Pryor 2016-05-05 03:38:57 UTC
Please provide a repro project which generates the unexpected error.
Comment 3 Cody Beyer (MSFT) 2017-08-23 20:51:17 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!